There are several HD wallet proposals. The most common one is BIP32, and a less common one is gmaxwell's proposal. Recently, we've been getting questions about both of them, both tagged with .

This seems confusing.

I propose moving one of them to a new tag.


  • I'm thoroughly confused, to be honest. I call it BIP32 because in pybitcointools the function is called bip32_hdm_. I'll read up on Greg's proposal ASAP. (PS. I'm blown away that I can FINALLY use Meta with iOS SE app! Woo!) Apr 15, 2015 at 7:47
  • Thats what really confused me at first. Also the wiki page for deterministic wallets is making this more complicated. I think they need a better classification.
    – abeikverdi
    Apr 15, 2015 at 15:53
  • @abeikverdi You're one of the people this affects; any idea how we should reclassify them?
    – Nick ODell
    Apr 15, 2015 at 17:30
  • @WizardOfOzzie The one you're asking about is BIP32. It's just that that's not the only HD wallet proposal. (PS. I know, right?)
    – Nick ODell
    Apr 15, 2015 at 17:32
  • I was thinking of splitting it into bip32 and non-bip32-hd-wallet. That wouldn't be elegant, but it would at least be clear.
    – Nick ODell
    Apr 15, 2015 at 19:52
  • 1
    @NickODell, Pieter Wuille at this video distinguished them by calling non-bip32-hd-wallet as a deterministic type 2 wallet.
    – abeikverdi
    Apr 20, 2015 at 6:06

1 Answer 1


I've merged into today, but then found this post. Sounds like I might have made a mistake. Will investigate further.

Update: according to a conversation with Pieter, Maxwell's proposal from 2011 introduced the term "deterministic wallets" but only BIP32 introduced hierarchical-deterministic wallets. Hence, anything labeled "HD-wallet" should refer to BIP32.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .